summaryrefslogtreecommitdiff
path: root/TAO/examples/POA/TIE/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/POA/TIE/Makefile.am')
-rw-r--r--TAO/examples/POA/TIE/Makefile.am68
1 files changed, 19 insertions, 49 deletions
diff --git a/TAO/examples/POA/TIE/Makefile.am b/TAO/examples/POA/TIE/Makefile.am
index 84100c426b3..71637e5ebf1 100644
--- a/TAO/examples/POA/TIE/Makefile.am
+++ b/TAO/examples/POA/TIE/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -16,41 +16,48 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-CLEANFILES =
noinst_PROGRAMS =
-BUILT_SOURCES =
-## Makefile.POA_TIE_Client.am
-
-if !BUILD_MINIMUM_CORBA
+## Makefile.POA_TIE_IDL.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
testC.cpp \
testC.h \
testC.inl \
+ testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-CLEANFILES += \
+CLEANFILES = \
test-stamp \
testC.cpp \
testC.h \
testC.inl \
+ testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-testC.cpp testC.h testC.inl testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@
+
+noinst_HEADERS = \
+ test.idl
+
+## Makefile.POA_TIE_Client.am
+
+if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
+
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -62,11 +69,7 @@ client_CPPFLAGS = \
client_SOURCES = \
client.cpp \
testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS_T.h \
- testS_T.inl
+ test_i.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
@@ -74,40 +77,12 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
## Makefile.POA_TIE_Server.am
if !BUILD_MINIMUM_CORBA
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl \
- testS_T.cpp \
- testS_T.h \
- testS_T.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl \
- testS_T.cpp \
- testS_T.h \
- testS_T.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
- @touch $@
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -121,11 +96,6 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS_T.h \
- testS_T.inl \
test_i.h
server_LDADD = \