summaryrefslogtreecommitdiff
path: root/TAO/examples/POA/TIE/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/POA/TIE/Makefile.am')
-rw-r--r--TAO/examples/POA/TIE/Makefile.am66
1 files changed, 48 insertions, 18 deletions
diff --git a/TAO/examples/POA/TIE/Makefile.am b/TAO/examples/POA/TIE/Makefile.am
index a8eee00155e..84100c426b3 100644
--- a/TAO/examples/POA/TIE/Makefile.am
+++ b/TAO/examples/POA/TIE/Makefile.am
@@ -16,48 +16,41 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.POA_TIE_IDL.am
+## Makefile.POA_TIE_Client.am
+
+if !BUILD_MINIMUM_CORBA
-BUILT_SOURCES = \
+BUILT_SOURCES += \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-CLEANFILES = \
+CLEANFILES += \
test-stamp \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+testC.cpp testC.h testC.inl testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
@touch $@
-
-noinst_HEADERS = \
- test.idl
-
-## Makefile.POA_TIE_Client.am
-
-if !BUILD_ACE_FOR_TAO
-if !BUILD_MINIMUM_CORBA
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -69,7 +62,11 @@ client_CPPFLAGS = \
client_SOURCES = \
client.cpp \
testC.cpp \
- test_i.h
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
@@ -77,12 +74,40 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
-endif !BUILD_ACE_FOR_TAO
## Makefile.POA_TIE_Server.am
if !BUILD_MINIMUM_CORBA
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -96,6 +121,11 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl \
test_i.h
server_LDADD = \