summaryrefslogtreecommitdiff
path: root/TAO/examples/Simple/bank/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Simple/bank/Makefile.am')
-rw-r--r--TAO/examples/Simple/bank/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/TAO/examples/Simple/bank/Makefile.am b/TAO/examples/Simple/bank/Makefile.am
index f18809908cf..0cf4f5f605a 100644
--- a/TAO/examples/Simple/bank/Makefile.am
+++ b/TAO/examples/Simple/bank/Makefile.am
@@ -16,8 +16,12 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.bank_IDL.am
+if BUILD_EXCEPTIONS
+
BUILT_SOURCES = \
BankC.cpp \
BankC.h \
@@ -45,9 +49,13 @@ Bank-stamp: $(srcdir)/Bank.idl $(TAO_IDL_DEP)
noinst_HEADERS = \
Bank.idl
+endif BUILD_EXCEPTIONS
+
## Makefile.bank_client.am
-noinst_PROGRAMS = client
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -76,8 +84,12 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif BUILD_EXCEPTIONS
+
## Makefile.bank_server.am
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -110,6 +122,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif BUILD_EXCEPTIONS
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*