summaryrefslogtreecommitdiff
path: root/TAO/examples/Simple/echo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Simple/echo/Makefile.am')
-rw-r--r--TAO/examples/Simple/echo/Makefile.am50
1 files changed, 42 insertions, 8 deletions
diff --git a/TAO/examples/Simple/echo/Makefile.am b/TAO/examples/Simple/echo/Makefile.am
index 6aaf119067a..371ddaa2e2a 100644
--- a/TAO/examples/Simple/echo/Makefile.am
+++ b/TAO/examples/Simple/echo/Makefile.am
@@ -16,7 +16,7 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-## Makefile.echo_IDL.am
+## Makefile.echo_client.am
BUILT_SOURCES = \
EchoC.cpp \
@@ -44,15 +44,9 @@ CLEANFILES = \
EchoC.cpp EchoC.h EchoC.inl EchoS.cpp EchoS.h EchoS.inl EchoS_T.cpp EchoS_T.h EchoS_T.inl: Echo-stamp
Echo-stamp: $(srcdir)/Echo.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Echo.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Echo.idl
@touch $@
-
-noinst_HEADERS = \
- Echo.idl
-
-## Makefile.echo_client.am
-
noinst_PROGRAMS = client
client_CPPFLAGS = \
@@ -66,9 +60,15 @@ client_CPPFLAGS = \
client_SOURCES = \
../Simple_util.cpp \
EchoC.cpp \
+ EchoS.cpp \
Echo_Client_i.cpp \
client.cpp \
../Simple_util.h \
+ EchoC.h \
+ EchoC.inl \
+ EchoS.h \
+ EchoS_T.h \
+ EchoS_T.inl \
Echo_Client_i.h
client_LDADD = \
@@ -84,6 +84,35 @@ client_LDADD = \
## Makefile.echo_server.am
+BUILT_SOURCES += \
+ EchoC.cpp \
+ EchoC.h \
+ EchoC.inl \
+ EchoS.cpp \
+ EchoS.h \
+ EchoS.inl \
+ EchoS_T.cpp \
+ EchoS_T.h \
+ EchoS_T.inl
+
+CLEANFILES += \
+ Echo-stamp \
+ EchoC.cpp \
+ EchoC.h \
+ EchoC.inl \
+ EchoS.cpp \
+ EchoS.h \
+ EchoS.inl \
+ EchoS_T.cpp \
+ EchoS_T.h \
+ EchoS_T.inl
+
+EchoC.cpp EchoC.h EchoC.inl EchoS.cpp EchoS.h EchoS.inl EchoS_T.cpp EchoS_T.h EchoS_T.inl: Echo-stamp
+
+Echo-stamp: $(srcdir)/Echo.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Echo.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -101,6 +130,11 @@ server_SOURCES = \
Echo_i.cpp \
server.cpp \
../Simple_util.h \
+ EchoC.h \
+ EchoC.inl \
+ EchoS.h \
+ EchoS_T.h \
+ EchoS_T.inl \
Echo_i.h
server_LDADD = \