summaryrefslogtreecommitdiff
path: root/TAO/examples/Simulator/Event_Supplier/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Simulator/Event_Supplier/Makefile.am')
-rw-r--r--TAO/examples/Simulator/Event_Supplier/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/TAO/examples/Simulator/Event_Supplier/Makefile.am b/TAO/examples/Simulator/Event_Supplier/Makefile.am
index 2cf702e1ad4..9b1fa8e053e 100644
--- a/TAO/examples/Simulator/Event_Supplier/Makefile.am
+++ b/TAO/examples/Simulator/Event_Supplier/Makefile.am
@@ -13,15 +13,13 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
## Makefile.Event_Supplier_IDL.am
-if BUILD_EXCEPTIONS
-
BUILT_SOURCES = \
./NavWeapC.cpp \
./NavWeapC.h \
@@ -46,15 +44,13 @@ CLEANFILES = \
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/../NavWeap.idl
@touch $@
+
noinst_HEADERS = \
../NavWeap.idl
-endif BUILD_EXCEPTIONS
-
## Makefile.Event_Supplier_DualEC_Sup.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += DualEC_Sup
@@ -93,13 +89,11 @@ DualEC_Sup_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Supplier_Event_Con.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
noinst_PROGRAMS += Event_Con
@@ -131,13 +125,11 @@ Event_Con_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Supplier_Event_Sup.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
noinst_PROGRAMS += Event_Sup
@@ -172,13 +164,11 @@ Event_Sup_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Supplier_Logging_Sup.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
noinst_PROGRAMS += Logging_Sup
@@ -213,7 +203,6 @@ Logging_Sup_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.