summaryrefslogtreecommitdiff
path: root/TAO/examples/ior_corbaloc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/ior_corbaloc/Makefile.am')
-rw-r--r--TAO/examples/ior_corbaloc/Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/TAO/examples/ior_corbaloc/Makefile.am b/TAO/examples/ior_corbaloc/Makefile.am
index 13645fa2108..493db46035e 100644
--- a/TAO/examples/ior_corbaloc/Makefile.am
+++ b/TAO/examples/ior_corbaloc/Makefile.am
@@ -13,11 +13,9 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
## Makefile.ior_corbaloc_IDL.am
BUILT_SOURCES = \
@@ -43,14 +41,13 @@ corbaloc-stamp: $(srcdir)/corbaloc.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/corbaloc.idl
@touch $@
+
noinst_HEADERS = \
corbaloc.idl
## Makefile.ior_corbaloc_client.am
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client
+noinst_PROGRAMS = client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -72,12 +69,8 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.ior_corbaloc_corbaname_client.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += corbaname_client
corbaname_client_CPPFLAGS = \
@@ -96,12 +89,8 @@ corbaname_client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.ior_corbaloc_server.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -126,8 +115,6 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*