summaryrefslogtreecommitdiff
path: root/TAO/interop-tests/wchar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/interop-tests/wchar/Makefile.am')
-rw-r--r--TAO/interop-tests/wchar/Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/TAO/interop-tests/wchar/Makefile.am b/TAO/interop-tests/wchar/Makefile.am
index cf9b92c5a38..27d5313153f 100644
--- a/TAO/interop-tests/wchar/Makefile.am
+++ b/TAO/interop-tests/wchar/Makefile.am
@@ -13,15 +13,11 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
## Makefile.interop_wchar_IDL.am
-if BUILD_EXCEPTIONS
-
BUILT_SOURCES = \
interop_wcharC.cpp \
interop_wcharC.h \
@@ -45,16 +41,13 @@ interop_wchar-stamp: $(srcdir)/interop_wchar.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/interop_wchar.idl
@touch $@
+
noinst_HEADERS = \
interop_wchar.idl
-endif BUILD_EXCEPTIONS
-
## Makefile.Interop_Wchar_Client.am
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client
+noinst_PROGRAMS = client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -73,12 +66,8 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.Interop_Wchar_Server.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -102,8 +91,6 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*