summaryrefslogtreecommitdiff
path: root/TAO/interop-tests/wchar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/interop-tests/wchar/Makefile.am')
-rw-r--r--TAO/interop-tests/wchar/Makefile.am53
1 files changed, 11 insertions, 42 deletions
diff --git a/TAO/interop-tests/wchar/Makefile.am b/TAO/interop-tests/wchar/Makefile.am
index 0a382f2f055..a77b1ea2cda 100644
--- a/TAO/interop-tests/wchar/Makefile.am
+++ b/TAO/interop-tests/wchar/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -16,12 +16,13 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-## Makefile.Interop_Wchar_Client.am
+## Makefile.interop_wchar_IDL.am
BUILT_SOURCES = \
interop_wcharC.cpp \
interop_wcharC.h \
interop_wcharC.inl \
+ interop_wcharS.cpp \
interop_wcharS.h \
interop_wcharS.inl \
interop_wcharS_T.cpp \
@@ -33,18 +34,25 @@ CLEANFILES = \
interop_wcharC.cpp \
interop_wcharC.h \
interop_wcharC.inl \
+ interop_wcharS.cpp \
interop_wcharS.h \
interop_wcharS.inl \
interop_wcharS_T.cpp \
interop_wcharS_T.h \
interop_wcharS_T.inl
-interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
+interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.cpp interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
interop_wchar-stamp: $(srcdir)/interop_wchar.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/interop_wchar.idl
@touch $@
+
+noinst_HEADERS = \
+ interop_wchar.idl
+
+## Makefile.Interop_Wchar_Client.am
+
noinst_PROGRAMS = client
client_CPPFLAGS = \
@@ -57,11 +65,6 @@ client_SOURCES = \
client.cpp \
interop_wcharC.cpp \
wchar_reference.cpp \
- interop_wcharC.h \
- interop_wcharC.inl \
- interop_wcharS.h \
- interop_wcharS_T.h \
- interop_wcharS_T.inl \
wchar_reference.h
client_LDADD = \
@@ -71,35 +74,6 @@ client_LDADD = \
## Makefile.Interop_Wchar_Server.am
-BUILT_SOURCES += \
- interop_wcharC.cpp \
- interop_wcharC.h \
- interop_wcharC.inl \
- interop_wcharS.cpp \
- interop_wcharS.h \
- interop_wcharS.inl \
- interop_wcharS_T.cpp \
- interop_wcharS_T.h \
- interop_wcharS_T.inl
-
-CLEANFILES += \
- interop_wchar-stamp \
- interop_wcharC.cpp \
- interop_wcharC.h \
- interop_wcharC.inl \
- interop_wcharS.cpp \
- interop_wcharS.h \
- interop_wcharS.inl \
- interop_wcharS_T.cpp \
- interop_wcharS_T.h \
- interop_wcharS_T.inl
-
-interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.cpp interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
-
-interop_wchar-stamp: $(srcdir)/interop_wchar.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/interop_wchar.idl
- @touch $@
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -114,11 +88,6 @@ server_SOURCES = \
interop_wchar_i.cpp \
server.cpp \
wchar_reference.cpp \
- interop_wcharC.h \
- interop_wcharC.inl \
- interop_wcharS.h \
- interop_wcharS_T.h \
- interop_wcharS_T.inl \
interop_wchar_i.h \
wchar_reference.h