summaryrefslogtreecommitdiff
path: root/TAO/interop-tests/wchar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/interop-tests/wchar/Makefile.am')
-rw-r--r--TAO/interop-tests/wchar/Makefile.am51
1 files changed, 41 insertions, 10 deletions
diff --git a/TAO/interop-tests/wchar/Makefile.am b/TAO/interop-tests/wchar/Makefile.am
index a999bd8b72f..0a382f2f055 100644
--- a/TAO/interop-tests/wchar/Makefile.am
+++ b/TAO/interop-tests/wchar/Makefile.am
@@ -16,13 +16,12 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-## Makefile.interop_wchar_IDL.am
+## Makefile.Interop_Wchar_Client.am
BUILT_SOURCES = \
interop_wcharC.cpp \
interop_wcharC.h \
interop_wcharC.inl \
- interop_wcharS.cpp \
interop_wcharS.h \
interop_wcharS.inl \
interop_wcharS_T.cpp \
@@ -34,25 +33,18 @@ CLEANFILES = \
interop_wcharC.cpp \
interop_wcharC.h \
interop_wcharC.inl \
- interop_wcharS.cpp \
interop_wcharS.h \
interop_wcharS.inl \
interop_wcharS_T.cpp \
interop_wcharS_T.h \
interop_wcharS_T.inl
-interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.cpp interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
+interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
interop_wchar-stamp: $(srcdir)/interop_wchar.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/interop_wchar.idl
@touch $@
-
-noinst_HEADERS = \
- interop_wchar.idl
-
-## Makefile.Interop_Wchar_Client.am
-
noinst_PROGRAMS = client
client_CPPFLAGS = \
@@ -65,6 +57,11 @@ client_SOURCES = \
client.cpp \
interop_wcharC.cpp \
wchar_reference.cpp \
+ interop_wcharC.h \
+ interop_wcharC.inl \
+ interop_wcharS.h \
+ interop_wcharS_T.h \
+ interop_wcharS_T.inl \
wchar_reference.h
client_LDADD = \
@@ -74,6 +71,35 @@ client_LDADD = \
## Makefile.Interop_Wchar_Server.am
+BUILT_SOURCES += \
+ interop_wcharC.cpp \
+ interop_wcharC.h \
+ interop_wcharC.inl \
+ interop_wcharS.cpp \
+ interop_wcharS.h \
+ interop_wcharS.inl \
+ interop_wcharS_T.cpp \
+ interop_wcharS_T.h \
+ interop_wcharS_T.inl
+
+CLEANFILES += \
+ interop_wchar-stamp \
+ interop_wcharC.cpp \
+ interop_wcharC.h \
+ interop_wcharC.inl \
+ interop_wcharS.cpp \
+ interop_wcharS.h \
+ interop_wcharS.inl \
+ interop_wcharS_T.cpp \
+ interop_wcharS_T.h \
+ interop_wcharS_T.inl
+
+interop_wcharC.cpp interop_wcharC.h interop_wcharC.inl interop_wcharS.cpp interop_wcharS.h interop_wcharS.inl interop_wcharS_T.cpp interop_wcharS_T.h interop_wcharS_T.inl: interop_wchar-stamp
+
+interop_wchar-stamp: $(srcdir)/interop_wchar.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/interop_wchar.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -88,6 +114,11 @@ server_SOURCES = \
interop_wchar_i.cpp \
server.cpp \
wchar_reference.cpp \
+ interop_wcharC.h \
+ interop_wcharC.inl \
+ interop_wcharS.h \
+ interop_wcharS_T.h \
+ interop_wcharS_T.inl \
interop_wchar_i.h \
wchar_reference.h