summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Dump_Schedule/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Dump_Schedule/Makefile.am')
-rw-r--r--TAO/orbsvcs/Dump_Schedule/Makefile.am55
1 files changed, 30 insertions, 25 deletions
diff --git a/TAO/orbsvcs/Dump_Schedule/Makefile.am b/TAO/orbsvcs/Dump_Schedule/Makefile.am
index 80ae24e06b5..926f30d88fc 100644
--- a/TAO/orbsvcs/Dump_Schedule/Makefile.am
+++ b/TAO/orbsvcs/Dump_Schedule/Makefile.am
@@ -1,35 +1,40 @@
-##---------------------------------------------------------------------------
-## $Id$
-##
-## Makefile for TAO's Dump Schedule Service
-##
-##---------------------------------------------------------------------------
-
-##
## Process this file with automake to create Makefile.in
-##
-## The number in AUTOMAKE_OPTIONS is the minimum required version automake
-## needed to process this file.
-AUTOMAKE_OPTIONS = 1.4
+ACE_ROOT = $(top_srcdir)/..
+ACE_BUILDDIR = $(top_builddir)/..
+TAO_ROOT = $(top_srcdir)
+TAO_BUILDDIR = $(top_builddir)
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+## Makefile.Dump_Schedule.am
-bin_PROGRAMS = Dump_Schedule
+noinst_PROGRAMS = Dump_Schedule
-Dump_Schedule_LDADD = \
- $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+Dump_Schedule_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs/orbsvcs
Dump_Schedule_SOURCES = \
- Dump_Schedul.cpp
-
-## noinst_HEADERS =
-
-## EXTRA_DIST = README
+ Dump_Schedule.cpp
-## Clean up some additional files/directories possibly created during
-## the configure script tests.
+Dump_Schedule_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTSched.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+
+## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
-
+ -rm -f gcctemp.c gcctemp so_locations
+ -rm -rf ptrepository SunWS_cache Templates.DB