summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/IFR_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/IFR_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/IFR_Service/Makefile.am222
1 files changed, 105 insertions, 117 deletions
diff --git a/TAO/orbsvcs/IFR_Service/Makefile.am b/TAO/orbsvcs/IFR_Service/Makefile.am
index 1f4881303ee..ef0f466d495 100644
--- a/TAO/orbsvcs/IFR_Service/Makefile.am
+++ b/TAO/orbsvcs/IFR_Service/Makefile.am
@@ -1,128 +1,116 @@
-##---------------------------------------------------------------------------
-## $Id$
-##
-## Makefile for TAO's Interface Repository Service
-##
-##---------------------------------------------------------------------------
-
-##
## Process this file with automake to create Makefile.in
-##
-## The number in AUTOMAKE_OPTIONS is the minimum required version automake
-## needed to process this file.
-AUTOMAKE_OPTIONS = 1.4
+ACE_ROOT = $(top_srcdir)/..
+ACE_BUILDDIR = $(top_builddir)/..
+TAO_ROOT = $(top_srcdir)
+TAO_BUILDDIR = $(top_builddir)
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+## Makefile.IFR_Service.am
-bin_PROGRAMS = IFR_Service
+noinst_PROGRAMS = IFR_Service
-IFR_Service_LDADD = \
- $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+IFR_Service_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
IFR_Service_SOURCES = \
- AliasDef_i.cpp \
- ArrayDef_i.cpp \
- AttributeDef_i.cpp \
- ComponentDef_i.cpp \
- ComponentRepository_i.cpp \
- ConstantDef_i.cpp \
- ConsumesDef_i.cpp \
- Contained_i.cpp \
- Container_i.cpp \
- EmitsDef_i.cpp \
- EnumDef_i.cpp \
- EventDef_i.cpp \
- ExceptionDef_i.cpp \
- FactoryDef_i.cpp \
- FinderDef_i.cpp \
- FixedDef_i.cpp \
- HomeDef_i.cpp \
- IDLType_i.cpp \
- IFR_BaseS.cpp \
- IFR_BasicS.cpp \
- IFR_ComponentsS.cpp \
- IFR_ExtendedS.cpp \
- IFR_Server.cpp \
- IFR_Service.cpp \
- InterfaceDef_i.cpp \
- IRObject_i.cpp \
- ModuleDef_i.cpp \
- NativeDef_i.cpp \
- OperationDef_i.cpp \
- Options.cpp \
- PrimaryKeyDef_i.cpp \
- PrimitiveDef_i.cpp \
- ProvidesDef_i.cpp \
- PublishesDef_i.cpp \
- Repository_i.cpp \
- SequenceDef_i.cpp \
- Servant_Factory.cpp \
- Servant_Locator.cpp \
- StringDef_i.cpp \
- StructDef_i.cpp \
- tmplinst.cpp \
- TypedefDef_i.cpp \
- UnionDef_i.cpp \
- UsesDef_i.cpp \
- ValueBoxDef_i.cpp \
- ValueDef_i.cpp \
- ValueMemberDef_i.cpp \
- WstringDef_i.cpp
+ IFR_Server.cpp \
+ IFR_Service.cpp
+
+IFR_Service_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_IFRService.la \
+ $(TAO_BUILDDIR)/tao/libTAO_TypeCodeFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
noinst_HEADERS = \
- AliasDef_i.h \
- ArrayDef_i.h \
- AttributeDef_i.h \
- ComponentDef_i.h \
- ComponentRepository_i.h \
- concrete_classes.h \
- ConstantDef_i.h \
- ConsumesDef_i.h \
- Contained_i.h \
- Container_i.h \
- EmitsDef_i.h \
- EnumDef_i.h \
- EventDef_i.h \
- ExceptionDef_i.h \
- FactoryDef_i.h \
- FinderDef_i.h \
- FixedDef_i.h \
- HomeDef_i.h \
- IDLType_i.h \
- IFR_BaseS.h \
- IFR_BasicS.h \
- IFR_ComponentsS.h \
- IFR_ExtendedS.h \
- IFR_Service.h \
- InterfaceDef_i.h \
- InterfaceS_T.h \
- IRObject_i.h \
- ModuleDef_i.h \
- NativeDef_i.cphp \
- OperationDef_i.h \
- Options.h \
- PrimaryKeyDef_i.h \
- PrimitiveDef_i.h \
- ProvidesDef_i.h \
- PublishesDef_i.h \
- Repository_i.h \
- SequenceDef_i.h \
- StringDef_i.h \
- StructDef_i.h \
- TypedefDef_i.h \
- UnionDef_i.h \
- UsesDef_i.h \
- ValueBoxDef_i.h \
- ValueDef_i.h \
- ValueMemberDef_i.h \
- WstringDef_i.h
-
-## EXTRA_DIST = README
-
-## Clean up some additional files/directories possibly created during
-## the configure script tests.
+ IFR_Service.h
+
+## Makefile.TAO_IFR_BE.am
+
+lib_LTLIBRARIES = libTAO_IFR_BE.la
+
+libTAO_IFR_BE_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/TAO_IDL/include \
+ -I$(TAO_ROOT)/TAO_IDL/fe \
+ -DTAO_IFR_BE_BUILD_DLL
+
+libTAO_IFR_BE_la_SOURCES = \
+ be_global.cpp \
+ be_init.cpp \
+ be_produce.cpp \
+ ifr_adding_visitor.cpp \
+ ifr_adding_visitor_exception.cpp \
+ ifr_adding_visitor_operation.cpp \
+ ifr_adding_visitor_structure.cpp \
+ ifr_adding_visitor_union.cpp \
+ ifr_removing_visitor.cpp \
+ ifr_visitor.cpp
+
+libTAO_IFR_BE_la_LDFLAGS = \
+ -version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
+
+libTAO_IFR_BE_la_LIBADD = \
+ $(TAO_BUILDDIR)/TAO_IDL/libTAO_IDL_FE.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+noinst_HEADERS += \
+ be_extern.h \
+ be_global.h \
+ ifr_adding_visitor_union.h \
+ ifr_adding_visitor_exception.h \
+ ifr_adding_visitor_structure.h \
+ ifr_adding_visitor_operation.h \
+ ifr_adding_visitor.h \
+ ifr_visitor.h \
+ ifr_removing_visitor.h
+
+
+## Makefile.TAO_IFR_EXE.am
+
+bin_PROGRAMS = tao_ifr
+
+tao_ifr_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs/IFR_Service \
+ -I$(TAO_ROOT)/TAO_IDL/include \
+ -I$(TAO_ROOT)/TAO_IDL/fe
+
+tao_ifr_SOURCES = \
+ $(TAO_ROOT)/TAO_IDL/driver/drv_args.cpp \
+ $(TAO_ROOT)/TAO_IDL/driver/drv_preproc.cpp \
+ $(TAO_ROOT)/TAO_IDL/tao_idl.cpp
+
+tao_ifr_LDADD = \
+ libTAO_IFR_BE.la \
+ $(TAO_BUILDDIR)/TAO_IDL/libTAO_IDL_FE.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+noinst_HEADERS += \
+ $(TAO_ROOT)/TAO_IDL/include/drv_extern.h
+
+## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
-
+ -rm -f gcctemp.c gcctemp so_locations
+ -rm -rf ptrepository SunWS_cache Templates.DB