summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/LifeCycle_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/LifeCycle_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/LifeCycle_Service/Makefile.am68
1 files changed, 38 insertions, 30 deletions
diff --git a/TAO/orbsvcs/LifeCycle_Service/Makefile.am b/TAO/orbsvcs/LifeCycle_Service/Makefile.am
index d456fd634f0..b1ca8c9c112 100644
--- a/TAO/orbsvcs/LifeCycle_Service/Makefile.am
+++ b/TAO/orbsvcs/LifeCycle_Service/Makefile.am
@@ -1,42 +1,50 @@
-##---------------------------------------------------------------------------
-## $Id$
-##
-## Makefile for TAO's Life Cycle Service
-##
-##---------------------------------------------------------------------------
-
-##
## Process this file with automake to create Makefile.in
-##
-## The number in AUTOMAKE_OPTIONS is the minimum required version automake
-## needed to process this file.
-AUTOMAKE_OPTIONS = 1.4
+ACE_ROOT = $(top_srcdir)/..
+ACE_BUILDDIR = $(top_builddir)/..
+TAO_ROOT = $(top_srcdir)
+TAO_BUILDDIR = $(top_builddir)
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+## Makefile.LifeCycle_Service.am
-bin_PROGRAMS = LifeCycle_Service
+noinst_PROGRAMS = LifeCycle_Service
-LifeCycle_Service_LDADD = \
- $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+LifeCycle_Service_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs/orbsvcs
LifeCycle_Service_SOURCES = \
- Criteria_Evaluator.cpp \
- Factory_Trader.cpp \
- LifeCycle_Service.cpp \
- LifeCycle_Service_i.cpp
+ Factory_Trader.cpp \
+ Criteria_Evaluator.cpp \
+ LifeCycle_Service.cpp \
+ LifeCycle_Service_i.cpp
-noinst_HEADERS = \
- Criteria_Evaluator.h \
- Factory_Trader.h \
- LifeCycle_Service.h \
- LifeCycle_Service_i.h
+LifeCycle_Service_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosLifeCycle.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
-## EXTRA_DIST = README
+noinst_HEADERS = \
+ LifeCycle_Service_i.h \
+ Factory_Trader.h \
+ Criteria_Evaluator.h \
+ LifeCycle_Service.h
-## Clean up some additional files/directories possibly created during
-## the configure script tests.
+## Clean up template repositories, etc.
clean-local:
-rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
-
+ -rm -f gcctemp.c gcctemp so_locations
+ -rm -rf ptrepository SunWS_cache Templates.DB