summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am b/TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am
new file mode 100644
index 00000000000..2bfd1e99121
--- /dev/null
+++ b/TAO/orbsvcs/Logging_Service/Basic_Logging_Service/Makefile.am
@@ -0,0 +1,46 @@
+## Process this file with automake to create Makefile.in
+
+ACE_ROOT = $(top_srcdir)/..
+ACE_BUILDDIR = $(top_builddir)/..
+TAO_ROOT = $(top_srcdir)
+TAO_BUILDDIR = $(top_builddir)
+
+## Makefile.Basic_Logging_Service.am
+
+noinst_PROGRAMS = Basic_Logging_Service
+
+Basic_Logging_Service_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -I$(TAO_ROOT)/orbsvcs/orbsvcs
+
+Basic_Logging_Service_SOURCES = \
+ Basic_Logging_Service.cpp
+
+Basic_Logging_Service_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+noinst_HEADERS = \
+ Basic_Logging_Service.h
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
+ -rm -f gcctemp.c gcctemp so_locations
+ -rm -rf ptrepository SunWS_cache Templates.DB