summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am b/TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am
index 496279e6e66..fcc727eb83c 100644
--- a/TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am
+++ b/TAO/orbsvcs/Logging_Service/Event_Logging_Service/Makefile.am
@@ -17,7 +17,7 @@ TAO_ROOT = $(top_srcdir)
## Makefile.Event_Logging_Service.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
bin_PROGRAMS = Event_Logging_Service
@@ -41,6 +41,7 @@ Event_Logging_Service_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_Utils.la \
$(TAO_BUILDDIR)/tao/libTAO_PI.la \
@@ -48,7 +49,6 @@ Event_Logging_Service_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsEventLogAdmin_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin_Skel.la \
@@ -62,7 +62,7 @@ Event_Logging_Service_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.