summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am35
1 files changed, 17 insertions, 18 deletions
diff --git a/TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am b/TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am
index 14d699263cd..8d9d161d35a 100644
--- a/TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am
+++ b/TAO/orbsvcs/Logging_Service/Notify_Logging_Service/Makefile.am
@@ -7,46 +7,45 @@ TAO_BUILDDIR = $(top_builddir)
## Makefile.Notify_Logging_Service.am
-if !BUILD_MINIMUM_CORBA
-
-bin_PROGRAMS = Notify_Logging_Service
+noinst_PROGRAMS = Notify_Logging_Service
Notify_Logging_Service_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
- -I$(TAO_ROOT)/orbsvcs \
-I$(TAO_BUILDDIR)/orbsvcs \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_ROOT)/orbsvcs/orbsvcs \
-DTAO_HAS_TYPED_EVENT_CHANNEL
Notify_Logging_Service_SOURCES = \
Notify_Logging_Server.cpp \
- Notify_Logging_Service.cpp \
- Notify_Logging_Service.h
+ Notify_Logging_Service.cpp
Notify_Logging_Service_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsNotifyLogAdmin_Serv.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin_Serv.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
- $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsNotifyLogAdmin_Skel.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Skel.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsEventLogAdmin_Skel.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin_Skel.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsNotifyLogAdmin.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsEventLogAdmin.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_DsLogAdmin.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif !BUILD_MINIMUM_CORBA
+noinst_HEADERS = \
+ Notify_Logging_Service.h
## Clean up template repositories, etc.
clean-local: