summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/Time_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/Time_Service/Makefile.am')
-rw-r--r--TAO/orbsvcs/Time_Service/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/TAO/orbsvcs/Time_Service/Makefile.am b/TAO/orbsvcs/Time_Service/Makefile.am
new file mode 100644
index 00000000000..a60c7f37596
--- /dev/null
+++ b/TAO/orbsvcs/Time_Service/Makefile.am
@@ -0,0 +1,40 @@
+##---------------------------------------------------------------------------
+## $Id$
+##
+## Makefile for TAO's Time Service
+##
+##---------------------------------------------------------------------------
+
+##
+## Process this file with automake to create Makefile.in
+##
+
+## The number in AUTOMAKE_OPTIONS is the minimum required version automake
+## needed to process this file.
+AUTOMAKE_OPTIONS = 1.4
+
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+
+bin_PROGRAMS = Time_Service_Server Time_Service_Clerk
+
+Time_Service_Server_LDADD = \
+ $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+
+Time_Service_Server_SOURCES = \
+ IR_Helper.cpp \
+ Server_i.cpp \
+ Time_Service_Server.cpp
+
+Time_Service_Clerk_LDADD = \
+ $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+
+Time_Service_Clerk_SOURCES = \
+ Clerk_i.cpp \
+ Time_Service_Clerk.cpp
+
+noinst_HEADERS = \
+ Clerk_i.h \
+ IR_Helper.h \
+ Server_i.h
+
+EXTRA_DIST = README