summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/examples/Notify/Lanes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/examples/Notify/Lanes/Makefile.am')
-rw-r--r--TAO/orbsvcs/examples/Notify/Lanes/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/TAO/orbsvcs/examples/Notify/Lanes/Makefile.am b/TAO/orbsvcs/examples/Notify/Lanes/Makefile.am
index 1797a1486f7..3115e27c5f6 100644
--- a/TAO/orbsvcs/examples/Notify/Lanes/Makefile.am
+++ b/TAO/orbsvcs/examples/Notify/Lanes/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -17,6 +17,7 @@ noinst_PROGRAMS =
## Makefile.Notify_Lanes_Consumer.am
+if BUILD_CORBA_MESSAGING
if BUILD_RT_CORBA
if !BUILD_MINIMUM_CORBA
@@ -45,9 +46,14 @@ Consumer_SOURCES = \
Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RT_Notification.la \
$(TAO_BUILDDIR)/tao/libTAO_RTCORBA.la \
+ $(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
$(TAO_BUILDDIR)/tao/libTAO_PI.la \
$(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -64,6 +70,7 @@ Consumer_LDADD = \
endif !BUILD_MINIMUM_CORBA
endif BUILD_RT_CORBA
+endif BUILD_CORBA_MESSAGING
## Makefile.Notify_Lanes_Supplier.am