summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am')
-rw-r--r--TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am b/TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am
index 39bee752b42..130c85fa5b5 100644
--- a/TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am
+++ b/TAO/orbsvcs/examples/Notify/ThreadPool/Makefile.am
@@ -18,8 +18,8 @@ noinst_PROGRAMS =
## Makefile.Notify_ThreadPool_Consumer.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Consumer
@@ -50,6 +50,7 @@ Consumer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RT_Notification.la \
$(TAO_BUILDDIR)/tao/libTAO_RTCORBA.la \
@@ -57,7 +58,6 @@ Consumer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
@@ -69,15 +69,15 @@ Consumer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Notify_ThreadPool_Supplier.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if BUILD_RT_CORBA
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Supplier
@@ -108,6 +108,7 @@ Supplier_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RT_Notification.la \
$(TAO_BUILDDIR)/tao/libTAO_RTCORBA.la \
@@ -115,7 +116,6 @@ Supplier_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_ETCL.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
@@ -127,8 +127,8 @@ Supplier_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.