summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am')
-rw-r--r--TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am b/TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am
index 011e6455fee..73c1ace16cb 100644
--- a/TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am
+++ b/TAO/orbsvcs/examples/RtEC/IIOPGateway/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -18,6 +18,7 @@ noinst_PROGRAMS =
## Makefile.RtEC_IIOPGateway.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Gateway
@@ -48,6 +49,7 @@ Gateway_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.RtEC_IIOPGateway_Consumer.am
@@ -87,6 +89,7 @@ endif BUILD_CORBA_MESSAGING
## Makefile.RtEC_IIOPGateway_EC.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += EC
@@ -117,6 +120,7 @@ EC_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.RtEC_IIOPGateway_Supplier.am