summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/examples/Security/Send_File/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/examples/Security/Send_File/Makefile.am')
-rw-r--r--TAO/orbsvcs/examples/Security/Send_File/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/TAO/orbsvcs/examples/Security/Send_File/Makefile.am b/TAO/orbsvcs/examples/Security/Send_File/Makefile.am
index a3e19081ec6..2834472db17 100644
--- a/TAO/orbsvcs/examples/Security/Send_File/Makefile.am
+++ b/TAO/orbsvcs/examples/Security/Send_File/Makefile.am
@@ -16,6 +16,8 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.Security_Send_File_Idl.am
BUILT_SOURCES = \
@@ -47,7 +49,9 @@ noinst_HEADERS = \
## Makefile.Security_Send_File_Client.am
-noinst_PROGRAMS = client
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -67,8 +71,12 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif BUILD_EXCEPTIONS
+
## Makefile.Security_Send_File_Server.am
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -91,6 +99,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif BUILD_EXCEPTIONS
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*