summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/orbsvcs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/orbsvcs/Makefile.am')
-rw-r--r--TAO/orbsvcs/orbsvcs/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/TAO/orbsvcs/orbsvcs/Makefile.am b/TAO/orbsvcs/orbsvcs/Makefile.am
index 2226b7b1f91..f1338572248 100644
--- a/TAO/orbsvcs/orbsvcs/Makefile.am
+++ b/TAO/orbsvcs/orbsvcs/Makefile.am
@@ -4032,6 +4032,7 @@ lib_LTLIBRARIES += libTAO_HTIOP.la
libTAO_HTIOP_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/protocols \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
-I$(TAO_ROOT)/orbsvcs \
@@ -4045,7 +4046,7 @@ libTAO_HTIOP_la_LDFLAGS = \
-version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
libTAO_HTIOP_la_LIBADD = \
- -lACE_HTBP \
+ $(ACE_BUILDDIR)/protocols/ace/HTBP/libACE_HTBP.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
@@ -4681,7 +4682,7 @@ libTAO_RTKokyuEvent_la_LDFLAGS = \
-version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
libTAO_RTKokyuEvent_la_LIBADD = \
- -lKokyu \
+ $(ACE_BUILDDIR)/Kokyu/libKokyu.la \
libTAO_RTSched.la \
libTAO_CosNaming.la \
libTAO_RTEvent.la \