summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am')
-rw-r--r--TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am31
1 files changed, 20 insertions, 11 deletions
diff --git a/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am b/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
index 211279d6c40..add39941212 100644
--- a/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
+++ b/TAO/orbsvcs/performance-tests/LoadBalancing/LBPerf/RPS/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -22,7 +22,8 @@ noinst_PROGRAMS =
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
BUILT_SOURCES = \
TestC.cpp \
@@ -30,7 +31,10 @@ BUILT_SOURCES = \
TestC.inl \
TestS.cpp \
TestS.h \
- TestS.inl
+ TestS.inl \
+ TestS_T.cpp \
+ TestS_T.h \
+ TestS_T.inl
CLEANFILES = \
Test-stamp \
@@ -39,18 +43,23 @@ CLEANFILES = \
TestC.inl \
TestS.cpp \
TestS.h \
- TestS.inl
+ TestS.inl \
+ TestS_T.cpp \
+ TestS_T.h \
+ TestS_T.inl
-TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl TestS_T.cpp TestS_T.h TestS_T.inl: Test-stamp
Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/Test.idl
@touch $@
+
noinst_HEADERS = \
Test.idl
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI
@@ -58,8 +67,8 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -97,8 +106,8 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI
@@ -106,8 +115,8 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -150,8 +159,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_MINIMUM_CORBA
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI