summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am')
-rw-r--r--TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am46
1 files changed, 32 insertions, 14 deletions
diff --git a/TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am b/TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am
index 788413b7e50..80b03cc86b5 100644
--- a/TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am
+++ b/TAO/orbsvcs/performance-tests/RTEvent/RTCORBA_Callback/Makefile.am
@@ -2,6 +2,11 @@
##
## $Id$
##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-config3/MPC/config -include /home/jtc/ACE/ACE-config3/MPC/templates -type automake TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -15,16 +20,16 @@ noinst_PROGRAMS =
CLEANFILES =
BUILT_SOURCES =
-## Makefile.RTCORBA_Callback_Idl.am
+## Makefile.RTCORBA_Callback_Client.am
if BUILD_CORBA_MESSAGING
if BUILD_RT_CORBA
if !BUILD_MINIMUM_CORBA
BUILT_SOURCES += \
+ TestS_T.inl \
TestC.inl \
TestS.inl \
- TestS_T.inl \
TestC.h \
TestS.h \
TestS_T.h \
@@ -34,9 +39,9 @@ BUILT_SOURCES += \
CLEANFILES += \
Test-stamp \
+ TestS_T.inl \
TestC.inl \
TestS.inl \
- TestS_T.inl \
TestC.h \
TestS.h \
TestS_T.h \
@@ -44,18 +49,15 @@ CLEANFILES += \
TestS.cpp \
TestS_T.cpp
-TestC.inl TestS.inl TestS_T.inl TestC.h TestS.h TestS_T.h TestC.cpp TestS.cpp TestS_T.cpp: Test-stamp
+TestS_T.inl TestC.inl TestS.inl TestC.h TestS.h TestS_T.h TestC.cpp TestS.cpp TestS_T.cpp: Test-stamp
Test-stamp: $(srcdir)/Test.idl
$(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Test.idl
@touch $@
-
-endif !BUILD_MINIMUM_CORBA
-endif BUILD_RT_CORBA
-endif BUILD_CORBA_MESSAGING
-
-## Makefile.RTCORBA_Callback_Client.am
+endif
+endif
+endif
if BUILD_CORBA_MESSAGING
if BUILD_RT_CORBA
@@ -75,15 +77,23 @@ client_CPPFLAGS = \
client_SOURCES = \
Callback.cpp \
- TestS.cpp \
TestC.cpp \
+ TestS.cpp \
client.cpp \
- Callback.h
+ Callback.h \
+ TestC.h \
+ TestS.h \
+ TestS_T.h \
+ TestC.inl \
+ TestS_T.inl
client_LDADD = \
../lib/libTAO_RTEC_Perf.la \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTCORBAEvent.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
@@ -119,16 +129,24 @@ server_CPPFLAGS = \
server_SOURCES = \
Session.cpp \
Session_Factory.cpp \
- TestS.cpp \
TestC.cpp \
+ TestS.cpp \
server.cpp \
Session.h \
- Session_Factory.h
+ Session_Factory.h \
+ TestC.h \
+ TestS.h \
+ TestS_T.h \
+ TestC.inl \
+ TestS_T.inl
server_LDADD = \
../lib/libTAO_RTEC_Perf.la \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTCORBAEvent.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \