summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am')
-rw-r--r--TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am172
1 files changed, 172 insertions, 0 deletions
diff --git a/TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am b/TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am
new file mode 100644
index 00000000000..752295ac9f6
--- /dev/null
+++ b/TAO/orbsvcs/performance-tests/RTEvent/lib/Makefile.am
@@ -0,0 +1,172 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.RTEC_Perf.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if BUILD_RT_CORBA
+if !BUILD_ACE_FOR_TAO
+
+BUILT_SOURCES = \
+ Federated_TestC.cpp \
+ Federated_TestC.h \
+ Federated_TestC.inl \
+ Federated_TestS.cpp \
+ Federated_TestS.h \
+ Federated_TestS.inl
+
+CLEANFILES = \
+ Federated_Test-stamp \
+ Federated_TestC.cpp \
+ Federated_TestC.h \
+ Federated_TestC.inl \
+ Federated_TestS.cpp \
+ Federated_TestS.h \
+ Federated_TestS.inl
+
+Federated_TestC.cpp Federated_TestC.h Federated_TestC.inl Federated_TestS.cpp Federated_TestS.h Federated_TestS.inl: Federated_Test-stamp
+
+Federated_Test-stamp: $(srcdir)/Federated_Test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -Wb,export_macro=TAO_RTEC_Perf_Export -Wb,export_include=rtec_perf_export.h $(srcdir)/Federated_Test.idl
+ @touch $@
+
+noinst_LTLIBRARIES = libTAO_RTEC_Perf.la
+
+libTAO_RTEC_Perf_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DTAO_RTEC_PERF_BUILD_DLL
+
+libTAO_RTEC_Perf_la_SOURCES = \
+ Client_Group.cpp \
+ Client_Options.cpp \
+ Client_Pair.cpp \
+ Consumer.cpp \
+ Control.cpp \
+ EC_Destroyer.cpp \
+ Federated_TestC.cpp \
+ Federated_TestS.cpp \
+ Implicit_Deactivator.cpp \
+ Loopback.cpp \
+ Loopback_Consumer.cpp \
+ Loopback_Pair.cpp \
+ Loopback_Supplier.cpp \
+ ORB_Holder.cpp \
+ ORB_Shutdown.cpp \
+ ORB_Task.cpp \
+ ORB_Task_Activator.cpp \
+ Peer_Base.cpp \
+ PriorityBand_Setup.cpp \
+ RTCORBA_Setup.cpp \
+ RTClient_Setup.cpp \
+ RTEC_Initializer.cpp \
+ RTPOA_Setup.cpp \
+ RTServer_Setup.cpp \
+ RT_Class.cpp \
+ Send_Task.cpp \
+ Send_Task_Stopper.cpp \
+ Supplier.cpp \
+ SyncScope_Setup.cpp
+
+noinst_HEADERS = \
+ Auto_Disconnect.cpp \
+ Auto_Disconnect.h \
+ Auto_Disconnect.inl \
+ Client_Group.h \
+ Client_Group.inl \
+ Client_Options.h \
+ Client_Pair.h \
+ Client_Pair.inl \
+ Consumer.h \
+ Control.h \
+ EC_Destroyer.h \
+ EC_Destroyer.inl \
+ Federated_Test.idl \
+ Federated_TestC.h \
+ Federated_TestC.inl \
+ Federated_TestS.h \
+ Federated_TestS.inl \
+ Implicit_Deactivator.h \
+ Implicit_Deactivator.inl \
+ Loopback.h \
+ Loopback_Consumer.h \
+ Loopback_Pair.h \
+ Loopback_Pair.inl \
+ Loopback_Supplier.h \
+ Low_Priority_Setup.cpp \
+ Low_Priority_Setup.h \
+ Low_Priority_Setup.inl \
+ ORB_Holder.h \
+ ORB_Holder.inl \
+ ORB_Shutdown.h \
+ ORB_Shutdown.inl \
+ ORB_Task.h \
+ ORB_Task.inl \
+ ORB_Task_Activator.h \
+ ORB_Task_Activator.inl \
+ Peer_Base.h \
+ PriorityBand_Setup.h \
+ PriorityBand_Setup.inl \
+ RIR_Narrow.cpp \
+ RIR_Narrow.h \
+ RTCORBA_Setup.h \
+ RTCORBA_Setup.inl \
+ RTClient_Setup.h \
+ RTClient_Setup.inl \
+ RTEC_Initializer.h \
+ RTPOA_Setup.h \
+ RTPOA_Setup.inl \
+ RTServer_Setup.h \
+ RTServer_Setup.inl \
+ RT_Class.h \
+ RT_Class.inl \
+ Send_Task.h \
+ Send_Task_Stopper.h \
+ Send_Task_Stopper.inl \
+ Servant_var.cpp \
+ Servant_var.h \
+ Servant_var.inl \
+ Shutdown.cpp \
+ Shutdown.h \
+ Shutdown.inl \
+ Supplier.h \
+ SyncScope_Setup.h \
+ SyncScope_Setup.inl \
+ Task_Activator.cpp \
+ Task_Activator.h \
+ Task_Activator.inl \
+ rtec_perf_export.h
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_RT_CORBA
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB