summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am30
1 files changed, 25 insertions, 5 deletions
diff --git a/TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am b/TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am
index 6fd64befbb9..c003c046e46 100644
--- a/TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am
+++ b/TAO/orbsvcs/tests/AVStreams/Component_Switching/Makefile.am
@@ -6,16 +6,20 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.AVS_Component_Switching_Dist.am
-noinst_PROGRAMS = distributer
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += distributer
distributer_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -34,15 +38,21 @@ distributer_SOURCES = \
distributer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Skel.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.AVS_Component_Switching_Recv.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += receiver
receiver_CPPFLAGS = \
@@ -62,15 +72,21 @@ receiver_SOURCES = \
receiver_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Skel.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.AVS_Component_Switching_Send.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += sender
sender_CPPFLAGS = \
@@ -90,13 +106,17 @@ sender_SOURCES = \
sender_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Skel.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*