summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am b/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
index b3189a2db61..cd48fe396a9 100644
--- a/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
+++ b/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
@@ -13,9 +13,13 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.AVS_Full_Profile_Ftp.am
-noinst_PROGRAMS = ftp
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += ftp
ftp_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -38,8 +42,12 @@ ftp_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.AVS_Full_Profile_Server.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -63,6 +71,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*