summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am22
1 files changed, 18 insertions, 4 deletions
diff --git a/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am b/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
index b3189a2db61..3db5feff051 100644
--- a/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
+++ b/TAO/orbsvcs/tests/AVStreams/Full_Profile/Makefile.am
@@ -6,16 +6,20 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.AVS_Full_Profile_Ftp.am
-noinst_PROGRAMS = ftp
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += ftp
ftp_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -31,15 +35,21 @@ ftp_SOURCES = \
ftp_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Skel.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.AVS_Full_Profile_Server.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -56,13 +66,17 @@ server_SOURCES = \
server_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_AV.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty_Skel.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosProperty.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*