summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am b/TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am
index 9604476e566..6dee1408491 100644
--- a/TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am
+++ b/TAO/orbsvcs/tests/EC_Custom_Marshal/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -21,7 +21,6 @@ noinst_PROGRAMS =
## Makefile.EC_Custom_Marshal_IDL.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
BUILT_SOURCES = \
dataC.cpp \
@@ -29,7 +28,10 @@ BUILT_SOURCES = \
dataC.inl \
dataS.cpp \
dataS.h \
- dataS.inl
+ dataS.inl \
+ dataS_T.cpp \
+ dataS_T.h \
+ dataS_T.inl
CLEANFILES = \
data-stamp \
@@ -38,24 +40,26 @@ CLEANFILES = \
dataC.inl \
dataS.cpp \
dataS.h \
- dataS.inl
+ dataS.inl \
+ dataS_T.cpp \
+ dataS_T.h \
+ dataS_T.inl
-dataC.cpp dataC.h dataC.inl dataS.cpp dataS.h dataS.inl: data-stamp
+dataC.cpp dataC.h dataC.inl dataS.cpp dataS.h dataS.inl dataS_T.cpp dataS_T.h dataS_T.inl: data-stamp
data-stamp: $(srcdir)/data.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/data.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -GT $(srcdir)/data.idl
@touch $@
+
noinst_HEADERS = \
data.idl
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.ECM_Consumer.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
noinst_PROGRAMS += ECM_Consumer
@@ -90,13 +94,11 @@ ECM_Consumer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.ECM_Supplier.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += ECM_Supplier
@@ -134,7 +136,6 @@ ECM_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.