summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/Basic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/Basic/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/Basic/Makefile.am32
1 files changed, 31 insertions, 1 deletions
diff --git a/TAO/orbsvcs/tests/Event/Basic/Makefile.am b/TAO/orbsvcs/tests/Event/Basic/Makefile.am
index 0bfc80aa48a..b68828bdc89 100644
--- a/TAO/orbsvcs/tests/Event/Basic/Makefile.am
+++ b/TAO/orbsvcs/tests/Event/Basic/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -18,6 +18,7 @@ noinst_PROGRAMS =
## Makefile.Event_Basic_Atomic_Reconnect.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Atomic_Reconnect
@@ -51,11 +52,13 @@ Atomic_Reconnect_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_BCast.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += BCast
@@ -89,11 +92,13 @@ BCast_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Bitmask.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Bitmask
@@ -135,11 +140,13 @@ Bitmask_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Complex.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Complex
@@ -181,11 +188,13 @@ Complex_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Control.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Control
@@ -219,11 +228,13 @@ Control_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Disconnect.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Disconnect
@@ -265,11 +276,13 @@ Disconnect_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Gateway.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Gateway
@@ -311,11 +324,13 @@ Gateway_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_MT_Disconnect.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += MT_Disconnect
@@ -349,11 +364,13 @@ MT_Disconnect_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Negation.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Negation
@@ -395,11 +412,13 @@ Negation_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Observer.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Observer
@@ -433,11 +452,13 @@ Observer_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Random.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Random
@@ -471,11 +492,13 @@ Random_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Reconnect.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Reconnect
@@ -509,11 +532,13 @@ Reconnect_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Shutdown.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Shutdown
@@ -547,11 +572,13 @@ Shutdown_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Timeout.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Timeout
@@ -593,11 +620,13 @@ Timeout_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Basic_Wildcard.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Wildcard
@@ -639,6 +668,7 @@ Wildcard_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.