summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am b/TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am
new file mode 100644
index 00000000000..443c61d62a5
--- /dev/null
+++ b/TAO/orbsvcs/tests/Event/Mcast/Common/Makefile.am
@@ -0,0 +1,53 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.ECMcastTests_lib.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
+
+noinst_LTLIBRARIES = libECMcastTests.la
+
+libECMcastTests_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DECMCASTTESTS_BUILD_DLL
+
+libECMcastTests_la_SOURCES = \
+ EC_Wrapper.cpp \
+ Gateway_EC.cpp
+
+noinst_HEADERS = \
+ ECMcastTests_export.h \
+ EC_Wrapper.h \
+ Gateway_EC.h
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB