summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am44
1 files changed, 31 insertions, 13 deletions
diff --git a/TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am b/TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am
index 0183cbdb41c..4404b172195 100644
--- a/TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am
+++ b/TAO/orbsvcs/tests/Event/Mcast/Two_Way/Makefile.am
@@ -1,13 +1,25 @@
## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-config3/MPC/config -include /home/jtc/ACE/ACE-config3/MPC/templates -type automake TAO.mwc
-ACE_ROOT = $(top_srcdir)/..
ACE_BUILDDIR = $(top_builddir)/..
-TAO_ROOT = $(top_srcdir)
+ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
-## Makefile.Two_Way_Application.am
+## Makefile.Two_Way_Application.am
-noinst_PROGRAMS = application
+if BUILD_CORBA_MESSAGING
+
+noinst_PROGRAMS += application
application_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -25,18 +37,21 @@ application_SOURCES = \
application_LDADD = \
../Common/libECMcastTests.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
- $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
$(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-## Makefile.Two_Way_Gateway_Ec.am
+endif BUILD_CORBA_MESSAGING
+
+## Makefile.Two_Way_Gateway_Ec.am
+
+if BUILD_CORBA_MESSAGING
noinst_PROGRAMS += gateway-ec
@@ -56,19 +71,22 @@ gateway_ec_SOURCES = \
gateway_ec_LDADD = \
../Common/libECMcastTests.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent_Skel.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
$(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
- $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
$(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif BUILD_CORBA_MESSAGING
+
## Clean up template repositories, etc.
clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
-rm -rf ptrepository SunWS_cache Templates.DB