summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/Performance/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/Performance/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/Performance/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/TAO/orbsvcs/tests/Event/Performance/Makefile.am b/TAO/orbsvcs/tests/Event/Performance/Makefile.am
index 22889225457..b37e6f11b58 100644
--- a/TAO/orbsvcs/tests/Event/Performance/Makefile.am
+++ b/TAO/orbsvcs/tests/Event/Performance/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -18,6 +18,7 @@ noinst_PROGRAMS =
## Makefile.Event_Performance_Connect.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Connect
@@ -51,11 +52,13 @@ Connect_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Performance_Inversion.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Inversion
@@ -89,11 +92,13 @@ Inversion_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Performance_Latency.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Latency
@@ -128,11 +133,13 @@ Latency_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Performance_Latency_Server.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Latency_Server
@@ -170,11 +177,13 @@ Latency_Server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Event_Performance_Throughput.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += Throughput
@@ -208,6 +217,7 @@ Throughput_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.