summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Event/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Event/lib/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Event/lib/Makefile.am42
1 files changed, 19 insertions, 23 deletions
diff --git a/TAO/orbsvcs/tests/Event/lib/Makefile.am b/TAO/orbsvcs/tests/Event/lib/Makefile.am
index cd26a1691d4..e655c581b5f 100644
--- a/TAO/orbsvcs/tests/Event/lib/Makefile.am
+++ b/TAO/orbsvcs/tests/Event/lib/Makefile.am
@@ -1,11 +1,19 @@
## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -include /home/jtc/ACE/ACE-config3/MPC/config -include /home/jtc/ACE/ACE-config3/MPC/templates -type automake TAO.mwc
-ACE_ROOT = $(top_srcdir)/..
ACE_BUILDDIR = $(top_builddir)/..
-TAO_ROOT = $(top_srcdir)
+ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
-## Makefile.Event_Test_Lib.am
+if BUILD_CORBA_MESSAGING
noinst_LTLIBRARIES = libECTests.la
@@ -25,33 +33,21 @@ libECTests_la_SOURCES = \
Driver.cpp \
Supplier.cpp
-libECTests_la_LDFLAGS = \
- -version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
-
-libECTests_la_LIBADD = \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_RTEvent.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
- $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
noinst_HEADERS = \
Consumer.h \
Counting_Consumer.h \
Counting_Supplier.h \
Driver.h \
+ Driver.i \
Supplier.h \
- ectest_export.h \
- Driver.i
+ ectest_export.h
+
+endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local:
- -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
- -rm -f gcctemp.c gcctemp so_locations
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
-rm -rf ptrepository SunWS_cache Templates.DB