summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am b/TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am
index 1577a4875b2..9beacbbe839 100644
--- a/TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am
+++ b/TAO/orbsvcs/tests/HTIOP/BiDirectional/Makefile.am
@@ -12,6 +12,7 @@ ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
@@ -44,8 +45,8 @@ CLEANFILES = \
testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
-test-stamp: $(srcdir)/test.idl
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@