summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am97
1 files changed, 97 insertions, 0 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am b/TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am
new file mode 100644
index 00000000000..7ee7f0b5e7a
--- /dev/null
+++ b/TAO/orbsvcs/tests/Notify/Bug_2926_Regression/Makefile.am
@@ -0,0 +1,97 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.Bug_2926_Regression_Lib.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_LTLIBRARIES = libbug2926.la
+
+libbug2926_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DBUG2926_BUILD_DLL
+
+libbug2926_la_SOURCES = \
+ DllORB.cpp
+
+noinst_HEADERS = \
+ DllORB.h
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Makefile.Bug_2926_Regression_Server.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS = server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DTAO_HAS_TYPED_EVENT_CHANNEL
+
+server_SOURCES = \
+ server.cpp \
+ DllORB.h \
+ bug2926_export.h
+
+server_LDADD = \
+ libbug2926.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(ACE_BUILDDIR)/ace/ETCL/libACE_ETCL_Parser.la \
+ $(TAO_BUILDDIR)/tao/ETCL/libTAO_ETCL.la \
+ $(ACE_BUILDDIR)/ace/ETCL/libACE_ETCL.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB