summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Destroy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Destroy/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Destroy/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Destroy/Makefile.am b/TAO/orbsvcs/tests/Notify/Destroy/Makefile.am
index 1e57ff1ede7..b9aa46216ab 100644
--- a/TAO/orbsvcs/tests/Notify/Destroy/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/Destroy/Makefile.am
@@ -16,6 +16,7 @@ TAO_ROOT = $(top_srcdir)
## Makefile.Notify_Test_Destroy.am
+if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS = Notify_Tests_Destroy
@@ -36,6 +37,13 @@ Notify_Tests_Destroy_SOURCES = \
Notify_Tests_Destroy_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -51,6 +59,7 @@ Notify_Tests_Destroy_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: