summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am b/TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am
index 5693bd22f7e..40c52148050 100644
--- a/TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/Reconnecting/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -17,6 +17,7 @@ noinst_PROGRAMS =
## Makefile.Reconnecting_Consumer.am
+if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Consumer
@@ -37,6 +38,13 @@ Consumer_SOURCES = \
Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -52,9 +60,11 @@ Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_CORBA_MESSAGING
## Makefile.Reconnecting_Supplier.am
+if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Supplier
@@ -75,6 +85,13 @@ Supplier_SOURCES = \
Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -90,6 +107,7 @@ Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: