summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am30
1 files changed, 24 insertions, 6 deletions
diff --git a/TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am b/TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am
index 77a4f7f2e40..d2add1b2deb 100644
--- a/TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am
+++ b/TAO/orbsvcs/tests/Notify/Sequence_Multi_Filter/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -50,8 +50,12 @@ go-stamp: $(srcdir)/go.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ go.idl
+
## Makefile.Seq_Multi_Filter_Ntf_Seq_Cons.am
+if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Consumer
@@ -69,13 +73,18 @@ Sequence_Consumer_CPPFLAGS = \
Sequence_Consumer_SOURCES = \
Notify_Sequence_Push_Consumer.cpp \
Sequence_Consumer.cpp \
- common.cpp \
goC.cpp \
- Notify_Sequence_Push_Consumer.h \
- common.h
+ Notify_Sequence_Push_Consumer.h
Sequence_Consumer_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -91,9 +100,11 @@ Sequence_Consumer_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_CORBA_MESSAGING
## Makefile.Seq_Multi_Filter_Ntf_Seq_Supp.am
+if BUILD_CORBA_MESSAGING
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += Sequence_Supplier
@@ -112,11 +123,17 @@ Sequence_Supplier_SOURCES = \
Sequence_Supplier.cpp \
goC.cpp \
goS.cpp \
- Notify_Sequence_Push_Consumer.h \
- common.h
+ Notify_Sequence_Push_Consumer.h
Sequence_Supplier_LDADD = \
$(TAO_BUILDDIR)/orbsvcs/tests/Notify/lib/libTAO_NotifyTests.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
$(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNotification_Serv.la \
$(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
@@ -132,6 +149,7 @@ Sequence_Supplier_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.
clean-local: