summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/Security/Big_Request/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/Security/Big_Request/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/Security/Big_Request/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/TAO/orbsvcs/tests/Security/Big_Request/Makefile.am b/TAO/orbsvcs/tests/Security/Big_Request/Makefile.am
index 69bd628a62a..21c8934a1bd 100644
--- a/TAO/orbsvcs/tests/Security/Big_Request/Makefile.am
+++ b/TAO/orbsvcs/tests/Security/Big_Request/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -43,13 +43,14 @@ TX_Object-stamp: $(srcdir)/TX_Object.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/TX_Object.idl
@touch $@
+
noinst_HEADERS = \
TX_Object.idl
## Makefile.Big_Request_Security_Client.am
-if BUILD_EXCEPTIONS
if BUILD_SSL
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -76,13 +77,13 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la \
@ACE_TLS_LIBS@
+endif !BUILD_ACE_FOR_TAO
endif BUILD_SSL
-endif BUILD_EXCEPTIONS
## Makefile.Big_Request_Security_Server.am
-if BUILD_EXCEPTIONS
if BUILD_SSL
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -112,8 +113,8 @@ server_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la \
@ACE_TLS_LIBS@
+endif !BUILD_ACE_FOR_TAO
endif BUILD_SSL
-endif BUILD_EXCEPTIONS
## Clean up template repositories, etc.
clean-local: