summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/tests/ior_corbaname/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/orbsvcs/tests/ior_corbaname/Makefile.am')
-rw-r--r--TAO/orbsvcs/tests/ior_corbaname/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/TAO/orbsvcs/tests/ior_corbaname/Makefile.am b/TAO/orbsvcs/tests/ior_corbaname/Makefile.am
index 0384f7ebf2f..52542ab8cec 100644
--- a/TAO/orbsvcs/tests/ior_corbaname/Makefile.am
+++ b/TAO/orbsvcs/tests/ior_corbaname/Makefile.am
@@ -13,11 +13,9 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
## Makefile.ior_corbaname_idl.am
BUILT_SOURCES = \
@@ -43,14 +41,13 @@ corbaname-stamp: $(srcdir)/corbaname.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/corbaname.idl
@touch $@
+
noinst_HEADERS = \
corbaname.idl
## Makefile.ior_corbaname_client.am
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client
+noinst_PROGRAMS = client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -73,12 +70,8 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Makefile.ior_corbaname_server.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -103,8 +96,6 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*