summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Callback/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Callback/Makefile.am')
-rw-r--r--TAO/performance-tests/Callback/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/TAO/performance-tests/Callback/Makefile.am b/TAO/performance-tests/Callback/Makefile.am
index 11cf0e3bf25..dc8918bcc07 100644
--- a/TAO/performance-tests/Callback/Makefile.am
+++ b/TAO/performance-tests/Callback/Makefile.am
@@ -13,14 +13,14 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
## Makefile.Callback_Perf_IDL.am
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
BUILT_SOURCES = \
callbackC.cpp \
@@ -45,15 +45,15 @@ callback-stamp: $(srcdir)/callback.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/callback.idl
@touch $@
+
noinst_HEADERS = \
callback.idl
-endif BUILD_EXCEPTIONS
+endif !BUILD_ACE_FOR_TAO
## Makefile.Callback_Client.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -84,13 +84,11 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Callback_Server.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -121,7 +119,6 @@ server_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.