summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Latency/Thread_Pool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Latency/Thread_Pool/Makefile.am')
-rw-r--r--TAO/performance-tests/Latency/Thread_Pool/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/TAO/performance-tests/Latency/Thread_Pool/Makefile.am b/TAO/performance-tests/Latency/Thread_Pool/Makefile.am
index 15b6ba7cab0..7182b371aeb 100644
--- a/TAO/performance-tests/Latency/Thread_Pool/Makefile.am
+++ b/TAO/performance-tests/Latency/Thread_Pool/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -16,8 +16,12 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+noinst_PROGRAMS =
+
## Makefile.Thread_Pool_Latency_Idl.am
+if !BUILD_ACE_FOR_TAO
+
BUILT_SOURCES = \
TestC.cpp \
TestC.h \
@@ -48,9 +52,16 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ Test.idl
+
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.Thread_Pool_Latency_Client.am
-noinst_PROGRAMS = client
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += client
client_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -70,8 +81,12 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.Thread_Pool_Latency_Server.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -96,6 +111,8 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*