summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/POA/Implicit_Activation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/POA/Implicit_Activation/Makefile.am')
-rw-r--r--TAO/performance-tests/POA/Implicit_Activation/Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/TAO/performance-tests/POA/Implicit_Activation/Makefile.am b/TAO/performance-tests/POA/Implicit_Activation/Makefile.am
index b3970226570..d6f4aa4d3a1 100644
--- a/TAO/performance-tests/POA/Implicit_Activation/Makefile.am
+++ b/TAO/performance-tests/POA/Implicit_Activation/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -43,12 +43,12 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St -Sa -St $(srcdir)/Test.idl
@touch $@
+
noinst_HEADERS = \
Test.idl
## Makefile.Implicit_Activation_Client.am
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -70,11 +70,9 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
## Makefile.Implicit_Activation_Collocated.am
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += collocated
@@ -99,12 +97,9 @@ collocated_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
## Makefile.Implicit_Activation_Server.am
-if BUILD_EXCEPTIONS
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -128,8 +123,6 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
-
## Clean up template repositories, etc.
clean-local:
-rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*