summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Protocols/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Protocols/Makefile.am')
-rw-r--r--TAO/performance-tests/Protocols/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/TAO/performance-tests/Protocols/Makefile.am b/TAO/performance-tests/Protocols/Makefile.am
index 3b4f19c77e2..f106715c2ff 100644
--- a/TAO/performance-tests/Protocols/Makefile.am
+++ b/TAO/performance-tests/Protocols/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -50,6 +50,9 @@ test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ test.idl
+
## Makefile.Protocols_Distributor.am
if BUILD_RT_CORBA
@@ -81,6 +84,8 @@ endif BUILD_RT_CORBA
## Makefile.Protocols_Receiver.am
+if !BUILD_ACE_FOR_TAO
+
noinst_PROGRAMS += receiver
receiver_CPPFLAGS = \
@@ -100,9 +105,12 @@ receiver_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.Protocols_Sender.am
if BUILD_RT_CORBA
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += sender
@@ -125,6 +133,7 @@ sender_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_RT_CORBA
## Clean up template repositories, etc.