summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am')
-rw-r--r--TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am b/TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am
new file mode 100644
index 00000000000..249ba4434c7
--- /dev/null
+++ b/TAO/performance-tests/RTCorba/Multiple_Endpoints/Common/Makefile.am
@@ -0,0 +1,81 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.RTCORBA_Common.am
+
+if BUILD_EXCEPTIONS
+if BUILD_RT_CORBA
+
+BUILT_SOURCES = \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl
+
+CLEANFILES = \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Wb,export_macro=RTCORBA_COMMON_Export -Wb,export_include=rtcorba_common_export.h $(srcdir)/test.idl
+ @touch $@
+
+noinst_LTLIBRARIES = libRTCORBA_Common.la
+
+libRTCORBA_Common_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DRTCORBA_COMMON_BUILD_DLL
+
+libRTCORBA_Common_la_SOURCES = \
+ testC.cpp \
+ testS.cpp \
+ test_i.cpp
+
+noinst_HEADERS = \
+ rtcorba_common_export.h \
+ test.idl \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS.inl \
+ test_i.h \
+ test_i.inl
+
+endif BUILD_RT_CORBA
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB