summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am')
-rw-r--r--TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am b/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
index 9684eade427..0e91b45fcb8 100644
--- a/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
+++ b/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -21,7 +21,6 @@ noinst_PROGRAMS =
## Makefile.Single_Threaded_AMH_Sequence_Idl.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
BUILT_SOURCES = \
TestC.cpp \
@@ -46,16 +45,15 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GH $(srcdir)/Test.idl
@touch $@
+
noinst_HEADERS = \
Test.idl
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Single_Threaded_AMH_Sequence_Client.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -83,13 +81,12 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_ACE_FOR_TAO
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
## Makefile.Single_Threaded_AMH_Sequence_Server.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -117,7 +114,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.