summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am')
-rw-r--r--TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am b/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
index 82597004129..a9425e5adaf 100644
--- a/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
+++ b/TAO/performance-tests/Sequence_Latency/AMH_Single_Threaded/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -52,11 +52,15 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ Test.idl
+
endif BUILD_CORBA_MESSAGING
## Makefile.Single_Threaded_AMH_Sequence_Client.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -82,11 +86,13 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Makefile.Single_Threaded_AMH_Sequence_Server.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -114,6 +120,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.