summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Sequence_Latency/AMI/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Sequence_Latency/AMI/Makefile.am')
-rw-r--r--TAO/performance-tests/Sequence_Latency/AMI/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/TAO/performance-tests/Sequence_Latency/AMI/Makefile.am b/TAO/performance-tests/Sequence_Latency/AMI/Makefile.am
index af35d0c6917..b851295dfa3 100644
--- a/TAO/performance-tests/Sequence_Latency/AMI/Makefile.am
+++ b/TAO/performance-tests/Sequence_Latency/AMI/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -22,7 +22,6 @@ noinst_PROGRAMS =
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
BUILT_SOURCES = \
TestC.cpp \
@@ -47,10 +46,10 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GC $(srcdir)/Test.idl
@touch $@
+
noinst_HEADERS = \
Test.idl
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI
@@ -58,7 +57,7 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += client
@@ -86,7 +85,7 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI
@@ -94,7 +93,7 @@ endif BUILD_AMI
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
noinst_PROGRAMS += server
@@ -124,7 +123,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI