summaryrefslogtreecommitdiff
path: root/TAO/performance-tests/Sequence_Latency/DSI/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/performance-tests/Sequence_Latency/DSI/Makefile.am')
-rw-r--r--TAO/performance-tests/Sequence_Latency/DSI/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/TAO/performance-tests/Sequence_Latency/DSI/Makefile.am b/TAO/performance-tests/Sequence_Latency/DSI/Makefile.am
index 83a4d0fa0f7..33792277792 100644
--- a/TAO/performance-tests/Sequence_Latency/DSI/Makefile.am
+++ b/TAO/performance-tests/Sequence_Latency/DSI/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -20,6 +20,7 @@ noinst_PROGRAMS =
## Makefile.DSI_Idl.am
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
BUILT_SOURCES = \
@@ -52,10 +53,15 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ Test.idl
+
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
## Makefile.DSI_Sequence_Client.am
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -78,10 +84,12 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
## Makefile.DSI_Sequence_Server.am
if BUILD_CORBA_MESSAGING
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -111,6 +119,7 @@ server_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.