summaryrefslogtreecommitdiff
path: root/TAO/tao/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tao/Makefile.am')
-rw-r--r--TAO/tao/Makefile.am25
1 files changed, 5 insertions, 20 deletions
diff --git a/TAO/tao/Makefile.am b/TAO/tao/Makefile.am
index dc550a9b8bb..15cb64ef9fe 100644
--- a/TAO/tao/Makefile.am
+++ b/TAO/tao/Makefile.am
@@ -44,7 +44,6 @@ PLUGGABLE_PROTOCOLS_FILES = \
UIOP_Acceptor.cpp \
UIOP_Connect.cpp \
IORC.cpp \
- IORS.cpp \
IORManipulation.cpp
PLUGGABLE_MESSAGING_FILES = \
@@ -98,11 +97,8 @@ ORB_CORE_FILES = \
ORB.cpp \
corbafwd.cpp \
PolicyC.cpp \
- PolicyS.cpp \
DomainC.cpp \
- DomainS.cpp \
TimeBaseC.cpp \
- TimeBaseS.cpp \
Principal.cpp \
Sequence.cpp \
MProfile.cpp \
@@ -141,9 +137,6 @@ ORB_CORE_FILES = \
LF_Follower.cpp \
LF_Follower_Auto_Ptr.cpp \
LF_Follower_Auto_Adder.cpp \
- Reactor_Registry.cpp \
- Single_Reactor.cpp \
- Reactor_Per_Priority.cpp \
params.cpp \
Resource_Factory.cpp \
Server_Strategy_Factory.cpp \
@@ -166,25 +159,24 @@ ORB_CORE_FILES = \
Asynch_Timeout_Handler.cpp \
Dynamic_Adapter.cpp \
IOPC.cpp \
- IOPS.cpp \
PollableC.cpp \
- PollableS.cpp \
CONV_FRAMEC.cpp \
- CONV_FRAMES.cpp \
Tagged_Components.cpp \
Services.cpp \
NVList.cpp \
MessagingC.cpp \
- MessagingS.cpp \
Policy_Manager.cpp \
Messaging_Policy_i.cpp \
TAOC.cpp \
- TAOS.cpp \
Buffering_Constraint_Policy.cpp \
GIOPC.cpp \
TAO_Singleton_Manager.cpp \
DLL_ORB.cpp \
- Endpoint_Selector_Factory.cpp
+ Endpoint_Selector_Factory.cpp \
+ Thread_Lane_Resources.cpp \
+ Thread_Lane_Resources_Manager.cpp \
+ Default_Thread_Lane_Resources_Manager.cpp
+
# Build a libtool library, libTAO.la for installation in libdir.
lib_LTLIBRARIES = libTAO.la
@@ -351,15 +343,12 @@ HEADER_FILES = \
Principal.h \
Profile.h \
Protocol_Factory.h \
- Reactor_Per_Priority.h \
- Reactor_Registry.h \
Resource_Factory.h \
Sequence.h \
Sequence_T.h \
Servant_Base.h \
Server_Strategy_Factory.h \
Services.h \
- Single_Reactor.h \
Stub.h \
Sync_Strategies.h \
TAO.h \
@@ -490,13 +479,10 @@ INLINE_FILES = \
PollableC.i \
PollableS.i \
PollableS_T.i \
- Pool_Per_Endpoint.i \
Principal.i \
Priority_Mapping.i \
Profile.i \
RT_Current.i \
- Reactor_Per_Priority.i \
- Reactor_Registry.i \
Reply_Dispatcher.i \
Synch_Reply_Dispatcher.i \
Asynch_Reply_Dispatcher.i \
@@ -504,7 +490,6 @@ INLINE_FILES = \
Sequence_T.i \
Servant_Base.i \
Services.i \
- Single_Reactor.i \
Stub.i \
Sync_Strategies.i \
TAO_Singleton.inl \